Description

The build settings for ZoneGraph do not get refreshed after the editor loads. Changing the snap distance or the snap angle will not be reflected in the ZoneGraph until you reload the editor. You can see this very well by changing settings to more drastic values from the defaults such as a distance of 100 and snap angle of 40. The reverse also happens that if you lower the values after loading the editor, it will use the larger values it read upon startup.

Steps to Reproduce
  1. Add ZoneGraph plugin to project
  2. Add 2 ZoneShapes to level
  3. Build ZoneGraph
    1. It is easier to do this with the setting for Build ZoneGraph Data While Editing in Project Settings->ZoneGraph
  4. Create Lane Profile with 2 lanes
  5. Assign lane profile to both ZoneShapes
  6. Move ZoneShapes to be end-to-end with less distance between the end points than the current build setting value for Connection Snap Distance in Project Settings->ZoneGraph
  7. The ZoneShapes should not connect with the chevron at the end of the shape remaining gray.
  8. Move ZoneShape to within snap distance.
  9. ZoneShapes should snap together and the chevron at the end of the shape should now be white indicating they are connected
  10. Move ZoneShape to back to distance greater than the snap distance
  11. Change snap distance in Project Settings to be larger value (i.e. 100)
  12. Move ZoneShape to see if it connects

Expected Result:

The ZoneShapes snap together using the new snap distance value.

Actual Result:

The ZoneShapes do not snap together unless moved to within the original value that was in the project settings when loading the editor.

Have Comments or More Details?

There's no existing public thread on this issue, so head over to Questions & Answers just mention UE-202359 in the post.

0
Login to Vote

Backlogged
ComponentUE - AI - Navigation
Affects Versions5.3.2
CreatedDec 11, 2023
UpdatedFeb 7, 2024
View Jira Issue