Developer Notes

This issue has been closed as 'Won't Fix' due to an extended period of time without updates. If this issue is important to you please let us know by posting on the AnswerHub or UDN, and Epic will re-open the ticket for further review.

Description

The Alpha Channel of the Render Target Texture is rendered as a value of 1 (solid white) when the SceneCapture2D actor is set to LDR with PP and Anti-Aliasing is set to true in the General Show Flags. With Anti-Aliasing set to false the Alpha Channel renders correctly.

AA=True:
[Image Removed]

AA=False:
[Image Removed]

Reproduced in Dev-Rendering CL 2817080 and 4.11 Preview 1

Steps to Reproduce

*Quick Reproduction in Attached 4.10.1 Project*

  1. Create a New Blank Project with No Starter Content
  2. Add a Scene Capture 2D actor
  3. Set the actor to use LDR with Post Process
  4. Duplicate the Scene Capture 2D actor
  5. In the Duplicate, under General Show Flags set Anti-Aliasing to False
  6. Add Two RenderTarget Textures and assign one to each of the Scene Capture 2D
  7. Build to make sure the Render Target Textures are filled in
  8. Open the Render Target Textures in the Texture Editor
  9. In both Textures only show the Alpha Channel

RESULTS: In the AA=True (Default) Scene Capture, the Alpha Channel renders as a value of 1 (Solid White)

EXPECTED: Both Textures retain the Alpha Values shown in the AA=False RenderTarget Texture

Have Comments or More Details?

There's no existing public thread on this issue, so head over toAnswerHub just mention UE-25112 in the post.

4
Login to Vote

Won't Fix
ComponentRendering
Affects Versions4.9.24.10.14.114.12
CreatedJan 8, 2016
ResolvedFeb 15, 2017
UpdatedApr 27, 2018