Developer Notes

This issue has been closed as 'Won't Fix' due to an extended period of time without updates. If this issue is important to you please let us know by posting on the AnswerHub or UDN, and Epic will re-open the ticket for further review.

Description

As the title suggests, whenever you attempt to add a third player using splitscreen, whenever the third player is created the viewport renders black. This only occurs when the viewport is sized to a specific width and height.

I tested this issue in the source build the licensee is reporting in, 4.10.2 - 2818068, as well as the binary releases of 4.9.2, 4.10.4, and 4.11 preview 6. The issue reproduces in all versions tested.

Steps to Reproduce

1. Download and Open test project.
2. Press PIE
3. Press the 'P' key twice to create additional players.

Note You might need to scale the viewport to a specific width to see the issue. I have noticed the size of the viewport is directly linked to the issue.

Outcome After pressing the 'P' key twice, the entire viewport renders black and doesn't return until you create another player.

Expected The viewport renders all the added players in their respective viewports correctly.

Tested and reproduced 4/4

Have Comments or More Details?

There's no existing public thread on this issue, so head over to Questions & Answers just mention UE-27394 in the post.

0
Login to Vote

Won't Fix
ComponentUE - Rendering
Affects Versions4.9.24.10.24.10.44.11
CreatedFeb 24, 2016
ResolvedFeb 14, 2017
UpdatedApr 27, 2018