Description

Note: I looked for a similar or related bug but could not find one. Sorry if it's here and buried.

Subsurface Profile materials render differently in the Material Editor Preview pane than they do anywhere else. This will make editing them in the actual editor (or the Material Instance Editor) essentially impossible, even for simple tweaks. And even if you didn't recommend editing them in that way, they just look broken within the Material Editor.

[Link Removed]
In this image, the character's skin (using Subsurface Profile) looks as expected.

[Link Removed]
Here's the mesh in the Static Mesh Editor. The lighting looks bad, but you can tell the material is working.

[Link Removed]
Here's the mesh in the Material Editor (a regular primitive looks just as bad)

To make sure it wasn't that particular material, here's the same thing with simple assets.

[Link Removed]
Sphere with a simple SSP material in a scene.

[Link Removed]
Same sphere in the Static Mesh editor with SSP material applied.

[Link Removed]
And that same sphere in the Material Editor.

Steps to Reproduce

In Release-4.14 branch, open the PhotoRealCharacter project (Samples/NotForLicensees).
Same done in Samples-Main branch, built to latest.

Select the head in the map and look in the details panel.

Open the head in the Static Mesh Editor and see how it renders.

Do the same thing with the M_Skin_Bust material found in Element 0 of the mesh.

For an apples-to-apples comparison, set the Preview Mesh in the Material Editor to the Bust mesh.

You can do the same thing in the Material Instance Editor, results will be the same.

Have Comments or More Details?

Head over to the existing Questions & Answers thread and let us know what's up.

4
Login to Vote

Fixed
ComponentUE - Rendering
Affects Versions4.144.15
Target Fix4.18
Fix Commit3620086
Main Commit3621569
Release Commit3643070
CreatedDec 15, 2016
ResolvedSep 6, 2017
UpdatedApr 27, 2018