Description

This is a common Mac crash occurring in the 4.16.1 release. I have not found any evidence of it occurring on Windows.

The callstack closely matches [Link Removed], which was briefly experienced by QA in 4.16.0, but then could not be reproduced later.

Users have not provided any descriptions, so additional information is currently unavailable.

Callstack from log

LogStreaming:Error: Couldn't find file for package /Engine/EngineDamageTypes/DmgTypeBP_Environmental requested by async loading code. NameToLoad: /Engine/EngineDamageTypes/DmgTypeBP_Environmental
Error: CDO Constructor (WorldSettings): Failed to find /Engine/EngineDamageTypes/DmgTypeBP_Environmental.DmgTypeBP_Environmental_C

LogStreaming:Error: Couldn't find file for package /Engine/EngineMaterials/WorldGridMaterial requested by async loading code. NameToLoad: /Engine/EngineMaterials/WorldGridMaterial
LogMac:Error: appError called: Assertion failed: Assertion failed: GDefaultMaterials[Domain] != NULL [File:/Users/build/Build/++UE4+Release-4.16+Compile/Sync/Engine/Source/Runtime/Engine/Private/Materials/Material.cpp] [Line: 433] 
Cannot load default material 'engine-ini:/Script/Engine.Engine.DefaultMaterialName'

LogMac: === Critical error: ===
SIGSEGV: invalid attempt to access memory at address 0x3

LogMac: FGenericPlatformMisc::RaiseException(unsigned int) Address = 0xb48882b  (filename not found) [in MyProject]
FOutputDeviceMacError::Serialize(wchar_t const*, ELogVerbosity::Type, FName const&) Address = 0xb62a5a4  (filename not found) [in MyProject]
FOutputDevice::Logf(wchar_t const*, ...) Address = 0xb6be10d  (filename not found) [in MyProject]
FDebug::AssertFailed(char const*, char const*, int, wchar_t const*, ...) Address = 0xb65cd8e  (filename not found) [in MyProject]
UMaterialInterface::InitDefaultMaterials() Address = 0xc57aac2  (filename not found) [in MyProject]
UClass::CreateDefaultObject() Address = 0xb9d273a  (filename not found) [in MyProject]
UMaterialInterface::PostCDOContruct() Address = 0xc57aedb  (filename not found) [in MyProject]
UClass::CreateDefaultObject() Address = 0xb9d273a  (filename not found) [in MyProject]
ProcessNewlyLoadedUObjects() Address = 0xbbb25e2  (filename not found) [in MyProject]
FEngineLoop::PreInit(wchar_t const*) Address = 0xb428610  (filename not found) [in MyProject]
GuardedMain(wchar_t const*) Address = 0xb439b4d  (filename not found) [in MyProject]
-[UE4AppDelegate runGameThread:] Address = 0xb44348a  (filename not found) [in MyProject]
-[FCocoaGameThread main] Address = 0xb5e84d6  (filename not found) [in MyProject]
__NSThread__start__() Address = 0x8bd66f24 (filename not found) [in Foundation]
_pthread_body() Address = 0x8e45999d (filename not found) [in libsystem_pthread.dylib]
_pthread_body() Address = 0x8e45991a (filename not found) [in libsystem_pthread.dylib]
thread_start() Address = 0x8e457351 (filename not found) [in libsystem_pthread.dylib]
Steps to Reproduce

repro steps currently unknown

Callstack
SEGV_MAPERR at 0x3

MyProject!UMaterialInterface::InitDefaultMaterials()
MyProject!UClass::CreateDefaultObject()
MyProject!UMaterialInterface::PostCDOContruct()
MyProject!UClass::CreateDefaultObject()
MyProject!ProcessNewlyLoadedUObjects()
MyProject!FEngineLoop::PreInit()
MyProject!GuardedMain()
MyProject!<Unknown>
MyProject!<Unknown>
Foundation!Unknown()
libsystem_pthread.dylib!<Unknown>
libsystem_pthread.dylib!<Unknown>
libsystem_pthread.dylib!<Unknown>

Have Comments or More Details?

There's no existing public thread on this issue, so head over to Questions & Answers just mention UE-46621 in the post.

1
Login to Vote

Fixed
ComponentUE - Rendering
Affects Versions4.16
Target Fix4.17
Fix Commit3542239
Main Commit3596628
Release Commit3542239
CreatedJun 28, 2017
ResolvedJul 18, 2017
UpdatedApr 27, 2018