Developer Notes

we don't support moving foliage between levels when there isn't a shared foliage asset. I know it worked previously in older versions, but this was a bug. For example there were issues if you moved only some of the foliage to another level and then tried to move it back again. It would appear as a separate foliage type to the foliage you never moved. In any situation using sublevels, a shared foliage asset is the recommended way of working.

Description

With 4.15, I can move Foliage to "Sublevel B", but I can not move it with 4.16. It seems to be affected by the update in 4.16 (New: When moving a foliage asset to a new level, you will now be prompted to save the Foliage Type as an asset if it's a local asset. From 4.16 ReleaseNote) .

Steps to Reproduce

1.Construct multiple SubLevels for PersistentLevel.
2.By drag and drop StaticMesh, add a foliage to "SubLevel A".
Whether you want to save it as a foliage asset, but press "Cancel".
Then, "SubLevel A" has local foliage.
3.Painting foliage "SubLevel A", and some selected.
4.Selected "SubLevel B" from the "Levels panel" -> On Right Click -> Selected "Move Selected Foliage to Level".
At this time, you are asked to save the asset, but you can not move the forge to "SubLevel B" even if I click "Cancel".

Have Comments or More Details?

There's no existing public thread on this issue, so head over toAnswerHub just mention UE-47355 in the post.

0
Login to Vote

Won't Fix
ComponentTools - Foliage
Affects Versions4.16
CreatedJul 18, 2017
ResolvedJul 18, 2017
UpdatedApr 27, 2018