Description

libtinfo.so.5 => /lib/x86_64-linux-gnu/libtinfo.so.5 (0x00007fc27cf4d000)

bschaefer@bschaefer-Precision-T7600:bin$ ldd ./clang
	linux-vdso.so.1 =>  (0x00007ffceefe3000)
	libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007fc27d582000)
	librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007fc27d37a000)
	libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007fc27d176000)
	libtinfo.so.5 => /lib/x86_64-linux-gnu/libtinfo.so.5 (0x00007fc27cf4d000)
	libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007fc27cbcb000)
	libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007fc27c8c2000)
	libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007fc27c6ac000)
	libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fc27c2e2000)
	/lib64/ld-linux-x86-64.so.2 (0x00007fc27d79f000)
Steps to Reproduce

Remove you current v14 toolchain for 4.23
Re-download it through the ./SetupToolchain.sh
Navigate to the clang++ binary in the downloaded toolchain for x86-x64 and run ldd on it to ensure libtinfo is not a depends anymore

Have Comments or More Details?

There's no existing public thread on this issue, so head over toAnswerHub just mention UE-79937 in the post.

0
Login to Vote

Fixed
ComponentPlatform - Linux
Affects Versions4.23
Target Fix4.23.1
CreatedSep 6, 2019
ResolvedSep 16, 2019
UpdatedSep 20, 2019