Scrubbing an Animation with Process Root Motion does not apply root motion

Anim - Gameplay - Oct 18, 2019

When EnabledRootMotion and Process Root Motion are both enabled for an animation with root motion, scrubbing an animation does not match the result of playing the animation. The playing animation al ...

State Machine events "Left State Event" and "Fully Blended State" not firing when animation is sequence is playing

Anim - Gameplay - Aug 28, 2019

State Machine events "Left State Event" and "Fully Blended State" not firing when animation is sequence is playing at the moment you enter/leave the state. ...

CachedLocalBounds is incorrectly updated

Anim - Gameplay - Apr 19, 2019

USkeletalMeshComponent::CalcBounds updates CachedLocalBounds by transforming the world FBoxSphereBounds, by the WorldToLocal transform, which is not sufficient to calculate the bounds in local space ...

Creating Anim Montage drops a frame(s)

Anim - Gameplay - Dec 13, 2018

When creating an animation montage, it appears that frames can be lost. ...

TimeStretchCurve doesn't work in Animation Montage

Anim - Gameplay - Oct 9, 2018

Using a TimeStretchCurve in an Animation Montage doesn't cause it to slow down or speed up when keys are added to the curve.  Link to API: [Link Removed] This was reported and tested in 4.20.3 (CL ...

Root Motion (RMFE) - Blend with cached pose causes inaccurate root motion

Anim - Gameplay - May 28, 2015

With Root Motion From Everything enabled, a Blend node gives different results when feeding it Animation Sequences directly or when first using a Cached Pose. *Simple test project attached Two sce ...