[CrashReport]UE4Editor-AudioMixerXAudio2!Audio::FMixerPlatformXAudio2::OpenAudioStream(Audio::FAudioMixerOpenStreamParams const &) [AudioMixerPlatformXAudio2.cpp:951]

Audio - Jul 15, 2021

This issue is occurring on startup for users. This could be potentially related to a recent Windows Update. ...

Audio Capture Component Crashes When Unplugging Mic/Headset

Audio - Jun 9, 2021

Audio Capture Component does not appear to be handling external device swaps appropriately, and has a delayed crash that will occur if an in-use mic is unplugged. At a glance, it appears to involve ...

Assertion failed: IsValid() in AudioDeviceManager.h related to dragging and dropping cues into the viewport

Audio - Feb 23, 2021

I was not able to reproduce this issue with the user given repro steps, however the crash has occurred for multiple users according to Crash Reporter, so it is worth investigating more into ...

Activate Reverb Effect node fails to activate when placed behind a Delay node

Audio - Feb 3, 2021

It seems that the Activate Reverb Effect node is no longer functioning when put behind a Delay node. In the test project, there is an empty actor with a Event Begin Play connected to a Delay node wh ...

Niagara Oscilloscope hangs indefinitely in cooked build

Audio - Dec 9, 2020

Cooked games will hang on startup when using the Oscilloscope data interface due to an indefinite wait in FNiagaraSubmixListener::UnregisterFromSubmix  When setting GCVarEnableAudioCommandLogging t ...

Editor crash when ticking then unticking "Toggle Visualization" in a Google Resonance Spatialization Settings window

Audio - Oct 23, 2020

This is a user reported crash, I was able to re-create in 4.25.4. I'm also assuming this happens in 4.26, however there is a current blocker that stops me from opening this project in 4.26. Linked ...

SessionFrontend Causes Lost Audio on iOS After Switching Apps

Audio - Oct 20, 2020

When using SessionFrontend on some devices, when leaving the app (going to the home screen or another app) or sometimes locking the device there is no more audio after returning to the game. "It lo ...

Sound Cue with Branch or Switch node has incorrect duration when played in a level sequence

Audio - Oct 19, 2020

Sound cues with a branch or switch node will show in the sequence with the longest duration of any waves within the cue, despite which one will be played. During playback the section length will dif ...

Crashing when Google Resonance is used with Soundfield Submix

Audio - Sep 17, 2020

When PIE'ing and stopping PIE with Google Resonance in use, the engine crashes after PIE session ended. Crash appears as a result of the Soundfield Submix's Soundfield Encoding Format being set to ...

OnAudioPlacebackPercentage PlaybackPercentage (float) doesn't take into account "Start Time" from Play or FadeIn nodes

Audio - Aug 17, 2020

PlaybackPercent on the OnAudioPlaybackPercent event does not account for Start Offset from the Play or FadeIn node. Reported and tested in version 4.25.3 (CL-13942748) and version 4.24.3 (CL-115903 ...