Niagara systems always compile on load.

Rendering - Niagara - Feb 1, 2019

Niagara System User Parameters Resetting After Closing the Editor

Rendering - Niagara - Jan 18, 2019

Niagara System user paramemters will reset upon restarting if they are used in a Blueprint. This also occurs to the system if you move the blueprint after making changes then pressing Ctrl+Z.  Foun ...

Packaged C++ Project Fatal Error on Startup When Spawning Niagara System Via a Character Blueprint

Rendering - Niagara - Jan 7, 2019

Using the system blueprint node in the character blueprint will cause the packaged game to give a fatal error when running the executable. This only occurs when in a C++ project. Found in 4.20 CL# ...

Migrating a Niagara asset from one project to copies the Niagara plugin assets

Rendering - Niagara - Jan 3, 2019

Migrating a Niagara asset from one project to copies the Niagara plugin assets. ...

Niagara Component is considered for GetActorBounds With "Only Colliding Components" Enabled

Rendering - Niagara - Dec 27, 2018

Niagara Component is considered for GetActorBounds With "Only Colliding Components" Enabled. Found in 4.20 CL# 4369336, 4.21 CL# 4613538, 4.22 CL# 4666322 ...

Dynamic input scripts crash when removing IF node's Pin and recreating it

Rendering - Niagara - Dec 19, 2018

This seems to happen with other NiagaraScript. According to Licensee, when this operation is done, it seems that the ID of the parameter is incorrect. ...

GPU Particles Don't Spawn at Correct Location When Used as Collision Event Receiver

Rendering - Niagara - Oct 8, 2018

GPU emitter doesn't spawn particles at expected location when it is an event receiver. Also disabling Interpolate Spawning in the emitter properties affect this behavior as well, making the particle ...

Niagara Translucency Sorting Issue with GPUCompute Sim

Rendering - Niagara - Sep 7, 2018

Niagara translucency sorting mode doesn't apply to a particle set to be GPUCompute Sim. Found in 4.20 CL# 4302132 and 4.21 CL# 4348893 ...

Niagara GPU Mesh Particles Not Working In Packaged Project

Rendering - Niagara - Aug 22, 2018

GPU Mesh emitters will not show up in a packaged project. Found in 4.20 CL# 4302132 and 4.21 CL# 4307852 ...