Description

A licensee is experiencing odd behavior when using custom code to call a loading movie when opening/loading a level.

The licensee has implemented a loading movie to play when calling a map to open via UMG widgets, and when they exit the application while the movie is opening, the audio continues to play. Upon re-opening the application, the screen would freeze until the movie was completed.

I attempted reproduce this on iOS, but I was unable to successfully compile the project for that platform. I received the message about not being able to launch code based projects so I had to compile from source. I did not have this issue when deploying to Android.

Steps to Reproduce

1. Download and Open attached project.
2. Launch to Android or iOS device.
3. Open any of the levels via the UMG widgets and allow video to play.
4. Press the 'Home' button to return to the home screen of the device.
5. Re-select the unreal project application to load it again.

Outcome Upon exiting the application using the home key, the audio continues to play in the background. Then when reloading the application, it becomes frozen and unresponsive. Project returns to normal upon video playback completion.

Expected Audio and video stop playing as soon as the application no longer has focus on the device. Then returning should either resume play and/or remain paused where it was exited.

Have Comments or More Details?

There's no existing public thread on this issue, so head over toAnswerHub just mention UE-38753 in the post.

2
Login to Vote

Fixed
ComponentMedia Framework
Affects Versions4.12.5
Target Fix4.16
Fix Commit3401056
Main Commit3427032
Release Commit3401056
CreatedNov 17, 2016
ResolvedApr 19, 2017
UpdatedSep 16, 2019