Description

There is a discrepancy between how Movie Scene Capture (Legacy) and Movie Render Queue handle letterboxing for sensor aspect ratio's that do not match the export resolution, which seems to be a bug with Movie Render Queue specifically for sensor aspect ratio's between 16:9 (1.78) and 1:1 (1), demonstrated in the attached GIF:
[Image Removed]
 
 
The frames have letterboxes burned in on render from either render method for most of the range:
 
[Image Removed]
 
The exception is those frames with a sensor aspect ratio between 16:9 and 1:1 do not have their letterbox burned in on the MRQ render only:
 
[Image Removed]

Steps to Reproduce

Using [Link Removed] (4.27):

  1. Open Main map (default)
  2. Open LetterboxTest_Animated Level Sequence in Sequencer

Or from scratch in 4.26 or 4.27 launcher versions:

  1. Create level sequence and add CineCamera Actor
  2. Animate camera actor's filmback sensor width attribute from ultra wide (i.e. 51mm) to ultra narrow (i.e. 4mm) over 3-5 seconds in Sequencer

Then:

  1. Render to image sequence using Movie Render Queue option 
  2. Render to image sequence using Movie Scene Capture (Legacy) option 
  3. Compare frames 81-95 in each export (those frames with a sensor aspect ratio between 1.78 and 1) – Movie Scene Capture render has letterbox while Movie Render Queue render does not

Have Comments or More Details?

There's no existing public thread on this issue, so head over to AnswerHub just mention UE-120483 in the post.

1
Login to Vote

Fixed
ComponentAnim - Sequencer
Affects Versions4.26.24.27
Target Fix4.27.1
Fix Commit17325515
CreatedJul 28, 2021
ResolvedAug 26, 2021
UpdatedSep 1, 2021