Description

I did some experiment locally. At very first I thought it's the image compression issue, since the issue is also obvious while rendered out images as JPG and PNG, there's no image compression quality settings in MRQ and the image size rendered out by MRQ is much smaller than the ones rendered by Sequencer legacy render. But after trying bmp the issue was still exist. Also the banding issue is vary in different color space. So I assume there might be something different in terms of Color converting while rendering out those images in MRQ

The banding issue is not visible in Editor viewport neither
 
 

Steps to Reproduce

This issue is more obvious in Dark gradient pixels, setting up such environment first is a easy way to reproduce it

  • Create a Postprocess Material(Before Tonemapping), feed a constant value 0.1 into Emissive input and save it.
  • Feed this PP material into the Postprocess volume added in the level, set the Vignette attributes to be 0.5, as well as the Exposure settings as images shows below
  • Create a Level Sequencer and add a camera track, so that in the camera view we can see a dark gradient Vignette effect, and ready to render it out to image
  • We are going to render one frame out by using two method, one is using MRQ and the other is using the legacy Sequencer render. The image format both side is set to bmp(see image below for reference)
  • Comparing the two images rendered by both ways, the MRQ one has much more banding issues(see image below, I also modify the origin images higher contrast in Photoshop for better visibility of the banding issue)

 
 

Have Comments or More Details?

There's no existing public thread on this issue, so head over to AnswerHub just mention UE-122226 in the post.

0
Login to Vote

Fixed
ComponentTools - Virtual Production - Color
Affects Versions4.27
Target Fix4.27.1
Fix Commit17324539
CreatedAug 21, 2021
ResolvedAug 26, 2021
UpdatedSep 1, 2021