Description

This is a regression. 
Maybe Binary only if it hasn't already been fixed.

Tested in:

Stream CL Type Results
//UE5/Main 18386535 Perforce Performance is normal after screenshot
//UE5/Main 18218925 Perforce  Performance is terrible in full screen; **
Normal outside of full screen.
//UE5/Main 18218925 Binary Performance is terrible after screenshot
//UE5/Release-5.0 16682836 Binary Performance is terrible after screenshot
//UE4/Release-4.27 18319896 Binary Performance is normal after screenshot

Using the High Resolution Screenshot tool while the viewport is in full screen causes the editor to stutter and lag after the screenshot is taken until the editor is restarted.

This is similar to [Link Removed], but not the same as this only occurs while the viewport is in full screen.

Steps to Reproduce
  1. Press F11 to full screen the view port
  2. Open the Viewport Options Menu from the top left corner
  3. Click High Resolution Screenshot
  4. In the High Resolution Screenshot dialog set the Screenshot Size Multiplier to 3.0
    • A warning is displayed about graphics driver potentially crashing.
  5. Click Capture

Expected Results:
Screenshot is taken and saved in the .../Saved/Screenshots/WindowsEditor folder. Editor performance returns to normal.

Actual Results:
Screenshot is taken and saved in the .../Saved/Screenshots/WindowsEditor folder. Editor continues to stutter and lag with high GPU usage.

Have Comments or More Details?

There's no existing public thread on this issue, so head over to Questions & Answers just mention UE-138552 in the post.

0
Login to Vote

Cannot Reproduce
ComponentUE - Rendering
Affects Versions5.0 early access5.1
Target Fix5.1
Fix Commit18931522
CreatedJan 6, 2022
ResolvedFeb 10, 2022
UpdatedFeb 10, 2022