Description

Low acceleration changes causes the object's velocity to nearly zero out. The range this seems to occur at for the Acceleration change is between the values of zero and approximately thirty.

Repro Rate: 4/4

Tested this in //UE4/Release-4.27 @ CL#18319896 and the issue did not occur there, it is a regression!

Steps to Reproduce
  1. Create a new Blank Blueprint project
  2. In the content browser, create a new Blueprint Class based on Actor
  3. Open and add a 'Cone' component
  4. In Details for the component, set 'Simulate Physics' to true and 'Enable Gravity' to false.
  5. Switch to the Event Graph and add in an "Add Impulse (Cone)" node
  6. Set impulse's X to 50.0 and enable 'Vel Change'
  7. Now add in an "Add Force (Cone)" node
  8. Set the force's X to 15.0 and enable 'Accel Change'
  9. Hook up the Event BeginPlay to 'Add Impulse'
  10. Save and Compile & place the Blueprint into the scene ensuring it's not colliding with anything
  11. Play in Editor & Observe
    • The cone should travel in one direction at a constant velocity.
  12. Return to the Blueprint and hook up the Event Tick to the 'Add Force' function
  13. Save & Compile
  14. Play in Editor & Observe

Results: Object stutters in place with velocity getting set to nearly zero.
Expected: Object retains it's velocity in addition to the change in velocity due to the acceleration.

Have Comments or More Details?

There's no existing public thread on this issue, so head over to Questions & Answers just mention UE-149771 in the post.

4
Login to Vote

Fixed
ComponentUE - Simulation - Physics
Affects Versions5.0
Target Fix5.1
Fix Commit19380083
Main Commit19380083
CreatedApr 20, 2022
ResolvedApr 25, 2022
UpdatedMay 6, 2022