Description

"ERROR: Client target not found!" When packaging client after enabling or disabling a plugin. This will happen on both developer or shipping client as the build configuration.

UATHelper: Packaging (Windows (32-bit)): Setting up ProjectParams for C:\Users\Username\Documents\Unreal Projects\MoreTest\MoreTest.uproject
UATHelper: Packaging (Windows (32-bit)): ERROR: Client target not found!
UATHelper: Packaging (Windows (32-bit)): (see D:\Main\Engine\Programs\AutomationTool\Saved\Logs\Log.txt for full exception trace)
PackagingResults: Error: Client target not found!
UATHelper: Packaging (Windows (32-bit)): AutomationTool exiting with ExitCode=1 (Error_Unknown)
UATHelper: Packaging (Windows (32-bit)): BUILD FAILED
PackagingResults: Error: Unknown Error

 

Found in 4.18 CL# 3832480, 4.19 CL# 4033788, and 4.21 CL# 4101872

Steps to Reproduce
  1. Open the Editor
  2. Create a new blank project
  3. Go to the Project Settings>Packaging and set the build configuration to "Shipping Client"
  4. Go to Plugins and enable any plugin not already enabled (I.e. Blueprint Stats)
  5. Restart the editor
  6. Try packaging the project as Windows(32-Bit)

Results:
The project will fail to package giving the error "ERROR: Client target not found!"

 

Expected:
The project will package properly.

Have Comments or More Details?

There's no existing public thread on this issue, so head over toAnswerHub just mention UE-59965 in the post.

5
Login to Vote

Backlogged
ComponentTools
Affects Versions4.184.194.21
CreatedJun 5, 2018
UpdatedJan 18, 2019