Description

When the "Enable Zero Iteration" and "Use ML Audio for Zero Iteration" settings are both checked, the audio doesn't play inside Unreal Editor. This happens in the following cases:

  • Playing an audio file in content browser
  • Playing the game from the editor (whether in Selected viewport, New editor Window, or as a Standalone Game) on the PC, without the Magic Leap device even being connected to the PC

This shouldn't be happening, the audio should be played via ML device only when testing it on the device via Zero Iteration.

This was tested and reported in 4.25.1 (CL-13594126). This was reproduced in 4.24.3 (CL-11590370) and Main 4.26 (CL-13653677)

Steps to Reproduce
  1. Open the UE4 Editor and create a First Person project
  2. In Project Settings check "Enable Zero Iteration" in "Magic Leap Plugin" section of the project settings and leave the "Use ML Audio for Zero Iteration" checked.
  3. Restart the Editor
  4. Navigate to FirstPerson/Audio and try to play FirstPersonTemplateWeaponFire02

Results: The audio doesn't play, there is no sound and it stops immediately

Expected: The audio should play. When checked, the option "Use ML Audio for Zero Iteration" should affect only the testing of the project via Zero Iteration, not playing audio files in editor

Have Comments or More Details?

There's no existing public thread on this issue, so head over toAnswerHub just mention UE-94317 in the post.

1
Login to Vote

Unresolved
ComponentAudio
Affects Versions4.24.34.25.14.26
Target Fix4.26
CreatedJun 14, 2020
UpdatedJun 15, 2020